e-猫楽園のサーバーをubuntu26.04LTSにバージョンアップしました。

サーバーに接続した際に、バージョンアップグレードの案内が表示されました。rootユーザーでdo-release-upgradを実行。”SSHでのバージョンアップグレードは、推奨しない”との警告が出ましたが、そのまま”y”で応答。バージョンアップグレードが開始されましたが、MySQLのアップグレードで、”rootユーザーおよびadminユーザーの認証プラグインが caching_sha2_passwordでは無い”と表示され、応答するとバージョンアップグレードが中断しました。

MySQLを起動して認証プラグインを変更しました。

・rootユーザーの認証プラグインを caching_sha2_password に変更
mysql> SELECT user,authentication_string,plugin,host FROM mysql.user WHERE user=’root’;
mysql> root | localhost | auth_socket |
mysql> ALTER USER ‘root’@’localhost’ IDENTIFIED WITH caching_sha2_password ‘Password12345’;
mysql> root | localhost | caching_sha2_password |
・adminユーザーの認証プラグインを caching_sha2_password に変更
mysql> SELECT user,authentication_string,plugin,host FROM mysql.user WHERE user=’admin’;
mysql> admin | localhost | auth_socket |
mysql> ALTER USER ‘admin’@’localhost’ IDENTIFIED WITH caching_sha2_password BY ‘Password12345’;
mysql> admin | localhost | caching_sha2_password |

再度、do-release-upgradを実行。
いくつかのアプリケーションのアップグレードで”現行の設定ファイルを継承するか”と聞かれましたので、すべて”y”で応答。2時間弱でバージョンアップグレードが完了して、サーバーを再起動しました。

障害1:メールクライアントでメールサーバーから受信出来ない。
原因1:10-ssl.confのパラメータが変更されたため、dovecotが起動できない。

10-ssl.confのキーファイルパラメータ書式変更(Let’s Encrypt用)
旧10-ssl.conf:
ssl_cert = </etc/letsencrypt/live/www.mywebsever.net/fullchain.pem
ssl_key = </etc/letsencrypt/live/www.mywebserver.net/privkey.pem
新10-ssl.conf:
ssl_server_cert_file = /etc/letsencrypt/live/www.mywebsever.net/fullchain.pem
ssl_server_key_file = /etc/letsencrypt/live/www.mywebsever.net/privkey.pem

変更後、dovecotを起動したところ、メールクライアントで受信が成功。

障害2:e-猫楽園のサイトは表示されるが、メディアライブラリへのファイルアップロードやPlug-inの更新が書き込みエラーで失敗する。サイトヘルスにも警告が表示されている。
原因2:各ディレクトリのパーミッションは従来通りのため、他の原因を探ったところ、Apache2の書込権限が”ro”になっていたため、すべての書込に失敗していることが判明。←セキュリティポリシーの強化?

Apache2のWordPressのインストールディレクトリに対する権限を変更(Read Only → Read & Write)

変更前:
# PID=$(pgrep -o apache2)
# sudo nsenter -t “$PID” -m — findmnt -T /home/web/wp -o TARGET,SOURCE,FSTYPE,OPTIONS
# TARGET SOURCE FSTYPE OPTIONS
# /home/web/wp/ /dev/mapper/ubuntu–vg-ubuntu–lv[/home/web/wp] ext4 ro,relatime

#sudo systemctl edit –drop-in=wordpress-writable.conf –stdin apache2 <<‘EOF’
#[Service] #ReadWritePaths=/home/web/wp
#EOF
#Successfully installed edited file ‘/etc/systemd/system/apache2.service.d/wordpress-writable.conf’.
変更後:
# PID=$(pgrep -o apache2)
# sudo nsenter -t “$PID” -m — findmnt -T /home/web/wp -o TARGET,SOURCE,FSTYPE,OPTIONS
# TARGET SOURCE FSTYPE OPTIONS
# /home/web/wp/ /dev/mapper/ubuntu–vg-ubuntu–lv[/home/wp/wp] ext4 rw,relatime
# service apache2 restart

メディアライブラリへのファイルアップロードやPlug-inの更新ができるようになりました。

コメントを残す

メールアドレスが公開されることはありません。 ※ が付いている欄は必須項目です

トップへ戻る